home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / ipw3945d-1.7.18 / ipw3945d-1.7.18.ebuild < prev    next >
Text File  |  2006-04-19  |  945b  |  35 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.18.ebuild,v 1.1 2006/04/13 21:30:26 brix Exp $
  4.  
  5. DESCRIPTION="Regulatory daemon for the Intel PRO/Wireless 3945ABG miniPCI express adapter"
  6.  
  7. HOMEPAGE="http://www.bughost.org/ipw3945/"
  8. SRC_URI="http://www.bughost.org/ipw3945/daemon/${P}.tgz"
  9.  
  10. LICENSE="ipw3945"
  11. SLOT="0"
  12. KEYWORDS="~x86"
  13.  
  14. IUSE=""
  15. DEPEND=""
  16.  
  17. src_install() {
  18.     into /
  19.     use x86 && dosbin x86/ipw3945d
  20.     use amd64 && dosbin x86_64/ipw3945d
  21.  
  22.     insinto /etc/modules.d/
  23.     newins ${FILESDIR}/${P}-modprobe.conf ${PN}
  24.  
  25.     dodoc README.ipw3945d
  26. }
  27.  
  28. pkg_postinst() {
  29.     einfo
  30.     einfo "A hook has been installed into the modprobe configuration in order to have"
  31.     einfo "the regulatory daemon automatically launched upon loading the ipw3945 driver."
  32.     einfo "You must run 'modules-update' for this hook to take affect."
  33.     einfo
  34. }
  35.